SlotForum banner
1 - 8 of 8 Posts

·
Premium Member
Joined
·
278 Posts
Discussion Starter · #3 ·
I have a proposal to how to solve this.

I keep the black Friday price until the bug is fixed + a few days.

In that way it will be possible to order the SSD already now to the reduced price if one can manage without the correction.

Or just wait until the bug is fixed and then still be able to pay the same price.

Is there anyone that want a SSD programmer for free? Here is how:

Send me one of the new chip (rev.H?) to me.

I will fix the bug and along with the rev.H chip I also send a SSD programmer for free.

PM me if there is anyone interested.
 

·
Premium Member
Joined
·
278 Posts
Discussion Starter · #7 ·
Yes I did. I got it a few days ago.

Up to now I have not had the time to set everything up so that I could start to test.

It will be very interesting to see where the problem is, since I have implemented the programming part exactly as it was described in this page, http://www.electricimages.co.nz/History.aspx?Page=SSD_Control&Revision=9#tab18188

for APB6.

What I will try first is to implement how the PBs before the APB6 was implemented. If that does not work then I will need someone to measure on a real APB6 to see if the protocol has changed with later APB6 firmware upgrades. The specification at electric images.co.nz is 5 years old.
 

·
Premium Member
Joined
·
278 Posts
Discussion Starter · #8 ·
Finally I got the time to troubleshoot this.

It turned out that I had too slow timing on the one- and zero-bits in the protocol. I used 120us and 240us where it turned out that it needed to be 116us and 232us. Now it works just fine with the new DPR-chip C8515.

Big thanks to Top Down for lending me a C8515-chip to use during my troubleshooting and verification!

The Black friday deal is still on, since this bug was found just days in advance of the deal.
 
1 - 8 of 8 Posts
Top