SlotForum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hello everybody, Just started on here and has already been a great help!

Anyways, I brought a digital 4 car powerbase the other day on ebay, working fine for a good, minute or so, then just stopped, no sign of burning out on the circuit board inside, and the transformer is still putting out power. The powerbase does warm when plugged in but the green light doesn't come on and no power seems to go to the track.

Would anyone know what the issue is and if theres a simple fix?

Jack
 

·
WRP World Champ 2015/2016
Joined
·
4,281 Posts
Welcome to the forum, jamracing. :wave:
My immediate reaction is "you've been tucked up, try and get a refund" take it to ebay's arbitration service if needed.
 

·
Registered
Joined
·
56 Posts
QUOTE (jamracing @ 6 Dec 2011, 23:23) <{POST_SNAPBACK}>Hello everybody, Just started on here and has already been a great help!

Anyways, I brought a digital 4 car powerbase the other day on ebay, working fine for a good, minute or so, then just stopped, no sign of burning out on the circuit board inside, and the transformer is still putting out power. The powerbase does warm when plugged in but the green light doesn't come on and no power seems to go to the track.

Would anyone know what the issue is and if theres a simple fix?

Jack

Sorry to hear you got a bum deal that's the risk of using ebay meh.

If your seller doesn't replace it I've got a brand new & tested one going spare you can have it for 'almost free' if that helps you out any.

give me a pm if you'd like it...
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
Ah, yeah thats what I feared! Well this ebayer had 100% good feedback, but hasn't replied at all to my message to him which I left a week ago now! Very anouying! but then again, thats the risk of ebay!

Thanks for the replies, and shall take ghost88 up on that offer!
 

·
Prof I T
Joined
·
11,159 Posts
hi
i do hope the 100% rating is about to be knocked back a peg or 2.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #8 ·
Yep, got the old one refunded and a new one which runs fine!
 
1 - 8 of 8 Posts
Top