SlotForum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi guys,

First post but I'm sure not my last - I just purchased the Scalextric Platinum set for my kids for Christmas, built a couple of tables and tonight I put together a small track to try it out. Everything worked great for about 1/2 hour then one of the lane changers quit working - it will actuate when the controller button is pressed to make a lane change but will not switch back to allow the car to drive straight through the next time. I have to manually push the flipper back to the straight position otherwise it just stays and the cars turn into the inside lane. All the other lane changers are working fine... any thoughts or ideas? Can these things be repaired or should I just order another lane changer? Bit of a let-down, hopefully it's something simple and I can get it fixed before Sunday!

One other question, the manual isn't all that great - how do I navigate the menu in order to slow the cars down and get a pace car running? I can't seem to get any of those screens to show up. My twins are only 5 and will probably spend most of their time at WOT for the first while, so I want to avoid any frustration on Christmas morning!

Appreciate any info.

P.S. as many others have mentioned, this hobby is highly addictive...already ordered more track and a police car to chase the kids around. It looks like I also need to find a laptop and purchase the software upgrade and cable soon as well!


Should be a fun Christmas morning!
 

·
Greg Gaub
Joined
·
14,656 Posts
Open up the big panel on the back of the lane changer that is having a problem. Look to see if the pin has fallen out of the little black piece that moves the flipper. You'll be able to tell from examining it if things aren't right. While you're there, look for anything that might be preventing it from moving freely, like glue or gunk or something. check the inside of the panel you removed as well. Hopefully there's something obvious that's causing the problem. The other possibility is that there is something in the slot preventing it from moving freely.

To learn how to use the base there are some videos and some great threads here on SlotForum. Start with this post which has links to the helpful threads:
http://www.slotforum.com/forums/index.php?showtopic=49996

Welcome to SlotFurm!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Thanks MrF. I will take it apart tomorrow night and check all those things out.

After I posted I happened upon your videos and was starting to play them. Great job - these will certainly help me get familiar with this set by the time Sunday rolls around!
 

·
Registered
Joined
·
50 Posts
Hi Greg. I discovered your vids on YouTube before seeing this post. Fair play to you! Without your vids, I seriously doubt that I would have managed to fathom pace cars. The manual is near useless.
 

·
Registered
Joined
·
433 Posts
Must say I never used the manual after watching Mr Flips videos, and pretty much haven't had a problem since. With the lane changer its pretty much like Mr Flip has said, usually a vacuum removes anything stuck in the slot and another simple fix is applying the tiniest amount of oil etc to the pin that moves the flippers, helped with a problem I had with the flipper not returning to the correct position so the cars were always changing lanes instead of going straight. Hope this helps.

Matt
 

·
WRP World Champ 2015/2016
Joined
·
4,279 Posts
Due credit to Mr F - saved me hours and hours of grief, last Christmas when my addiction first began. Or maybe I should berate him, because without the help of Mr F's videos I might have given up and stuck it in a cupboard. Think of the money I could have saved
 

·
Premium Member
Joined
·
10,109 Posts
Hi Oerboost - what did the DVD that came with the platinum set have on it? I expected it to be the equivalent of Mr F's youtube instructional videos.
 

·
Greg Gaub
Joined
·
14,656 Posts
Thanks, guys. Let's not divert this thread any more, though.

Hopefully Overboost can report back on his lane change solution soon.
I'm also curious about the DVD with the set, but my expectation is a compilation of the videos Adrian did.
 

·
Registered
Joined
·
10 Posts
Hey guys, I am happy to report that I found the problem: it was exactly what MrF said above - one of the L-hooks coming out of a solenoid had popped off the plastic bracket it was supposed to be connected to (not sure what the company uses for glue but it didn't seem to hold very well).
Anyhow I used some super glue, put the lane change back together and everything is working great now! Thanks to everyone, especially MrF, who took the time to post! I almost ordered another set of lane changers today but I'm glad I held off.

Re: the documentation, I just looked through everything that I received in the box and a DVD was not included. Only a warranty card, a couple of instruction manuals (one for the set and one for programming) and a 2011 catalog were in there. Who needs an instruction manual with a site like this anyway?!?

Today I ordered a cable from SSDC. I also have a bunch more track, a police car and the digital chip to convert it (all found on Ebay) coming in the mail. Tonight I finished my tables (one 6 ft X 8 ft and one 4 ft X 8 ft, to be set up in an L shape) and gave them a quick coat of light gray paint. I nailed a 1 in. tall border around the perimeter and I am thinking of putting some foam sponge around the perimeter to ease the impact when things get out of control.

Using MrF's videos I was able to navigate the various menus much easier - I got the cars slowed down and had a pace car running as well. Next step is to inventory all the track I will have and figure out a nice layout.

Thanks again everyone!
 

·
WRP World Champ 2015/2016
Joined
·
4,279 Posts
Good news, don't be shy about posting track plans or pictures of the build process


I, on the other hand, need to go and post elsewhere about a very sad straight LC I have.
 
1 - 11 of 11 Posts
Top