SlotForum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2,574 Posts
Discussion Starter · #1 ·
My MSC 6R4 has a problem. The crown keeps spinning on the axle.
The grub screw doesn't hold the crown tight for more than a couple of laps.

Has anyone else had this problem? Any ideas as to a cure? I do have an idea of something I could do (which I'm to embarrassed to post here) but if I resort to that, the crown would never come off the axle again, and that potentially could cause problems of it's own.


I've also got the MSC RS200 and that seems to be fine.

TIA
 

·
Registered
Joined
·
2,831 Posts
Mine doesn't have that problem but the separate brass "guide" thingy next to the crown, that is not connected to the gear, did move. Until I tightened it.

Best bet would be to loosen the crown, slide it to one side and file a small flat on the axle.

If you must, a small drop of super glue on the end of a pin into the gap between the axle and gear may suffice. Easily removed with nail polish remover (acetone).
 

·
Registered
Joined
·
3,748 Posts
Mine did this as well, the MSC axles seem to be a bit soft, I used superglue and the grub screw to hold mine in place, as the wheels are push fit I didn't want to take them off to fit another axle and gear which would be the proper way to fix it.
 

·
Registered
Joined
·
551 Posts
I've had this problem on my MSC RS200, plus on my Metro and when I checked my MSC Subaru and Scaleauto SLS Mercedes (same parts it seems) they too were a bit loose. I used some liquid threadlocker I have and it solved the problem.

Generally I think they are great cars but this particular problem is an issue which I hope they sort out in later releases
 

·
Registered
Joined
·
2,574 Posts
Discussion Starter · #5 ·
Thanks for the input lads.


As ever, some obvious solutions I hadn't thought of.
 
1 - 5 of 5 Posts
Top