SlotForum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter · #1 ·
Hi,

I'm Dan. I have been reading various topics on here over the last few months after rediscovering scalextric when my other half bought me a little set for christmas! I am now totally addicted again and its kind of taken over my life!

This is my first post on here and i'm hoping to pick peoples brains for help/advice and help on where to post any questions I may have. I have set out what i feel is quite a large layout and have possibly bit off more than i can chew for a beginner!


look forward to hearing from you all!

Dan
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #2 ·
I'll add a little more info now...!

The track I have is to be a permanent one and is set out in an outbuilding at the back of my pub (no beer taps/pumps in there though... yet!!!)

It is laid out on four 8ftx4ft sheets of plywood arranged in a 'U Shape' I have run the track for a few weeks and am happy with the layout having left room for scenery, pit area etc etc. (will try add a pic of my track layout asap)

I have fixed in place all my raised sections and 'sunk' the track into 6mm MDF sat on top of the ply and have done the odd bit of scenery work (expanding foam for cliff faces/papier mache/some basic LED lighting) basically playing around!

Having sat back and thought hard! I think I need to take a look at what I have got myself involved in and work out a plan of action, I am having some issues with power to the track (minimum power in some areas and a couple of heavy power surges to the cars in others) so want to sort these issues before i go any further!

HELP!!!
 

·
David Jessett
Joined
·
255 Posts
Hi Dan,

Welcome to the Forum. There's more knowledge on here than anywhere else I know about Slot racing. I'm sure you are right to get the running issues sorted out before you go too far with the scenery.

You don't say what type of track you have or whether you are running the standard race management system with it or anything extra. Also it's always great to see some pictures if you can do that.

David
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #4 ·
Hi David,

Thanks for the reply! I am currently running scalextric sport analogue (all new stuff bought in the last 2 months) from their standard powerbase, I did at one point swap to a digital 4 car powerbase and added a couple of lane changers and a pit lane however couldnt quite get into it so have swapped back to analogue (the digital track parts are still in place though, could this be causing my power issues?) there is also 4 analogue crossovers on the track too...

I need to pop out and get some extra track to replace the digital track and will see how I get on from there..!
 
1 - 5 of 5 Posts
Top