SlotForum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter · #1 ·
I am having trouble with the power dying on my ninco circuit when i race 2 ninco cars for about 20 laps( tis only a short track with 4 straights and a couple of corners). When i try to run a Fly truck on its own it lasts for 10 laps before dying.
Any suggestions very welcome. Am new to slotcars.
 

·
Registered
Joined
·
303 Posts
QUOTE (branco @ 6 Jan 2005, 04:29)I am having trouble with the power dying on my ninco circuit when i race 2 ninco cars for about 20 laps( tis only a short track with 4 straights and a couple of corners). When i try to run a Fly truck on its own it lasts for 10 laps before dying.
Any suggestions very welcome. Am new to slotcars.
<{POST_SNAPBACK}>

Sounds like it is trying to limit the current to reduce heat build-up?!?!?!?!?!
Does the power supply get too hot to touch when used??????
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #3 ·
QUOTE (daleg @ 7 Jan 2005, 01:26)QUOTE (branco @ 6 Jan 2005, 04:29)I am having trouble with the power dying on my ninco circuit when i race 2 ninco cars for about 20 laps( tis only a short track with 4 straights and a couple of corners). When i try to run a Fly truck on its own it lasts for 10 laps before dying.
Any suggestions very welcome. Am new to slotcars.
<{POST_SNAPBACK}>

Sounds like it is trying to limit the current to reduce heat build-up?!?!?!?!?!
Does the power supply get too hot to touch when used??????
<{POST_SNAPBACK}>


No it does not get hot nor is there a burning smell. Could it be the magnets in the fly trucks?
 
1 - 3 of 3 Posts
Top