Slot Cars Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
i got it out for my boys bought two new cars and it won't work it acts as though it's not plugged in. does anyone know what could cause this problem. the cars won't work on any part of the track. everything looks to be in perfect condition at the untrained eye. i look at the tracks controllers and power pack. i see no visible issues. even looking through the vents in the controller it appears to look new inside. please help my kids want to race
 

·
Registered
Joined
·
3,748 Posts
Could be dirty track rails, try cleaning them with a mild abrasive, like wet and dry paper or wire wool.
Other than that it could be that the power pack is gone.
Do the cars wheels turn round if you put a 9V battery on the pickups?

Where are you located, someone local might be able to help you on Xmas day.
 

·
Registered
Joined
·
3 Posts
alright well i got the track back out after i was upset it wasn't working earlier. i can push the cars on the track that the power pack is connected to and get the car to go about 3 inches. i cannot get anything out of any of the other pieces of track. will cleaning the top part of the rails fix the issue or will i need to lightly sand all four connecting pieces of metal that contact each track piece.
 

·
Registered
Joined
·
1,842 Posts
Start with the smallest oval you can make - one straight either side - then clean the oxidation from the top of the rails, starting with the power straight. If just doing the top of the rails is insufficient plug and unplug the track sections a few times. That will clean the joints with least effort. If there's an improvement but the cars still hesitate at the joints, clean the joints more thoroughly and try them again. You'll also find that once you can get the cars to go round a couple of times without stopping they will help clean the tops of the rails too.

When you've found the best way to get them running, progress to doing more track the same way.

You will also need to keep an eye on the pickups on the cars (the metal sleds underneath) as they will blacken as they burn off the oxidation from the track and will need cleaning themselves.

The good thing is, once it's all working it shouldn't need such intense effort to keep it running in future.

Good luck - and enjoy!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
well i got it going last night i cleaned the rails with a damp soft brillo pad and it shined the rails right up. i started with the track that th power pack is attached to and they zipped right down it so i did the rest and the cars are going as they should thanks for all the help. my boys thank you also
 
1 - 5 of 5 Posts
Top