SlotForum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
hi guys. im new here. ive been playing around with the oxigen stuff for a month now.
i only have apple products and it seems i can not install the latest firmware on my c chips. i have tried uploading O2-0315 with nrf app and it says it was successful but then when i move over to the slot it app it sees the chip but when i try to register it says its obsolete firmware??
also when i change settings through the controller you hold down the down arrow and the brake button it tells you the track number and then channel. if you hold down up and down arrows and brake button it is supposed to tell you the mode also. mine does not. anyone else have this problem?

cheers
jason
 

·
ParrotGod
Joined
·
9,269 Posts
Time to switch to Android! ;-)
Some of the suggestions here on Apple devices seem to suggest to turn off and on bt before updating the firmware.
Which version of the app are you using?

As for the controller mode, I believe (but I might be wrong) that the mode is gone from the controller programming routing - I haven't seen my doing it for ages.
 

·
Greg Gaub
Joined
·
15,353 Posts
The LC LED mode has been moved to the app and bootloader, so you won't see it when pairing a car any more.

For the registration process, make sure you have a stable internet connection, preferably wifi.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #5 · (Edited)
thanks greg.
the chip was previously paired to anopther phone app from the shop i bought it from. he has an oxigen track where we play and race. would that effect the migration?
he has deleted my stuff from his phone
i am using the scp-3

EDIT: when i update the chip from the nrf app to O2 0315 the slot it app then sees the chip but says it is inactive and then the obsolete message. i have tried the BT on off a couple of times, no luck.

guess i will have to wait until the IOS app supports updating
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #6 · (Edited)
if i put the older O2 0306 firmware back into the chip it will work with my scp-3 on the carrera track, without lane changers working, but with the latest firmware it will not pair to the car. is this to be expected?

so confirm i am trying to load the right firmware? O2 315?
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #7 ·
bit of an update....
i have tried many times today to try get one of my chips to register with the app to no avail.

i have tried the turning BT and app off but unfortunately didnt work.
i can upload latest firmware through nrf app but when i try to register i get this message....

Brown Font Rectangle Screenshot Parallel


the firmware i am uploading is 0201c-02-0315b-210825

if i tried the D132 firmware i get the same result


interestingly the cars will not run on either of the latest firmwares. i have to go back to the obsolete ones to get the cars to go.


Brown Font Rectangle Screenshot Parallel
 

·
Greg Gaub
Joined
·
15,353 Posts
If that chip was registered using someone else's account, I don't think it can be registered using yours. That device will need to remove your chip from it's list of registered chips. I've never tried this, but that's what I assume would be the case.

Older firmware doesn't have that registration requirement, but also doesn't support stuff like changing the LC LED mode from the app, so it's best to use the latest firmware.
 

·
ParrotGod
Joined
·
9,269 Posts
I think he said that the shop owner has deleted the devices from his phone. Whether this works on the back end I am not sure because I have never tried.
The error message is anyway around the firmware loaded on the device being obsolete so it appears it does not recognize the new firmware in the chip.
 

·
Greg Gaub
Joined
·
15,353 Posts
Ah, I missed that.

The other thing I see mentioned sometimes with regard to Apple devices being silly is the need to enable Location Services, or to toggle if off and then on, like often suggested for Bluetooth.
 

·
Registered
Joined
·
809 Posts
The problems with oxygen and Apple have been around for years now. I have no insight into Slot.it's thinking of course but it seems to me that they have little interest in fixing the problems. I feel they are fortunate indeed to have so many ardent defenders on this forum who will explain that the problems are with Apple or the users themselves. I can only speak for myself but I'll just say that I have spent far more time struggling with oxygen software than actually racing oxygen cars. So much so that I've effectively given up on oxygen. Which is a shame.
 
1 - 20 of 24 Posts
Top