SlotForum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi ,

I'm new to the forum but understand that you guys are the Gurus of many thing including Digital powerbases.

I have bought a job lot of scalextric which includes a C7030 power base. Unfortunately, I left it with the kids who tried to set up and think they have blown it up.

I've tested it as per one of your threads (with a multi meter and only have 0.6v at the 5v and 12v fuses. (https://www.slotforu...howtopic=191281)

I'd like to try the kids on more cars but dont want to shell out on an New power base C7042 etc just yet.

Hope you guys can help.

Andy
 

·
Administrator
Joined
·
10,123 Posts
Welcome to the forum!

OK so it could be many things but key things are PSU, fuses, mosfets

Check the power supply when not connected to the powerbase, it should read 12V. Do this first as they do fail!

Second check the fuses. Use you meter to measure resistance across each fuse, it should be less than an ohm. If it isn't then success! solder a tiny strand of wire bridging the fuse, that will suffice.

Last if its neither of the above then check the resistances of the mosfets. The two devices are identical, use that as the way of spotting if one is faulty. A very low reading on one and not the other means the first is dead. PM me then and 'll send you some.
 

·
Administrator
Joined
·
10,123 Posts
OK Andy I understand that you have drawn a blank, which version of c7030 powerbase is it? Version 1.5 with the mosfets on the vertical daughter baord, or 1.2-1.4 which have two chips down on the main board?
 
1 - 3 of 3 Posts
Top