SlotForum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2,879 Posts
Hi

I'm using the SCP-01 with a Scalextric C7042 powerbase.

When I start racing the controller behaves normally. However, quite frequently, whilst doing fast practice laps on a small oval circuit, the controller sometimes automatically moves the braking point from zero up to roughly half way on the trigger scale and it remains there (with the green light on) until I release the trigger completely, then it goes back to normal.

I can't recreate it when I try, but it seems to happen after about a minute and when the trigger has been just moving in the top half of the scale ie 50% to 100% without ever coming back to rest (zero point). It happens in all the knob, CV switch and dip switch positions.

The only thing I've changed was to loosen the trigger pivot screw a little as the trigger became stiff and jammed on at full speed position. Also the spring makes some noise.

So, I presume this automatic temporary recalibration is not normal - is it a fault or should I try to reset/reprogram the controller?

Chris
 

·
Vendor
Joined
·
2,920 Posts
Chris,
I'd suggest two things:

1 - make sure the magnet is not loose in its cradle.

2 - lube the screw and all the pivot mechanism of the controller. It tends to stick but if you follow this advice
http://www.slot.it/Download/FAQ_PDF_en/15-StickySCP1.en.pdf
it will go away. Then, tighten the screw up. It is designed to work when tight - if you loosen it up, trigger position readouts become very unreliable, hence (possibly) your trouble.

Regards
Maurizio
 

·
Registered
Joined
·
2,879 Posts
Spot on with no. 2. All lubed up and tightened up and back to normal. Thanks for your help.

I must say this controller is a pure pleasure to use - thanks for giving birth to it!

Cheers
Chris
 
1 - 4 of 4 Posts
Top