SlotForum banner
1 - 2 of 2 Posts

·
Greg Gaub
Joined
·
14,988 Posts
Discussion Starter · #1 ·
I was reminded of a problem that seems pretty consistent when I install slot.it SSD chips (SISP12) into slot.it cars. One that's been around for ages, and one that's new.

1) the wires that come off the board to go to the guide being soldered on "straight ahead" is a bad thing. The channel for the wires to go under the front axle to the guide are slightly off to the left and right sides of the chip itself. Plus, the chip is firmly up against the stiffeners of the chassis under the front axle and behind the guide. The result is that the wires are either dangerously forced into a harsh bend, or more often, I have to desolder and resolder the guide wires on so that they come off at a slight angle outward, or directly to the side. The wire can then gently bend and follow the channel to the nose of the car. No offense, but is no one installing SISP12 chips into slot.it cars in Italy any more? ;-) Give it a try, and I'm sure you'll quickly see what I mean.

2) the new heavy wires to the motor are too thick to easily fit into the wiring retainers on the chassis. I don't understand why that wire is thicker anyway. If that needs to be thicker, shouldn't the guide wire be the same? I wonder if you tried, but realized it wouldn't fit through the channels under the front axle.
Well, the bottleneck will still be at the front end through the guide wires, so I don't understand the point of the heavy wire from the chip to the motor. It's also really stiff. I'd prefer the motor lead wire be like it was before... the same as stock slot.it motor lead wire.

Don't take these minor quibbles as complaining about the system. I love how easy it is to chip slot.it cars with the slot.it chip. It's near enough to DPR simplicity as possible. If the two above issues could be taken care of, it would be even closer. You could take it to the next step and put spade connectors on the motor leads like the Ninco chip, I guess, but those might fall off. If I was to REALLY nitpick, I'd suggest the assemblers cut the through-hole wire tips off a little closer to the board so that it can properly lay flat on the chassis. That's something I've also taken to doing with new chip installs.

Anyway, great system. Hopefully it can be made that much better.
 
1 - 2 of 2 Posts
Top