Slot Cars Forum banner

1 - 5 of 5 Posts

·
Mike
Joined
·
629 Posts
Discussion Starter · #1 ·
Having read thro the digital throttle postings I cannot find the answer to my needs.
My throttle goes to 3/4 and is then flat out, if you go past 3/4 the car then goes slower.
I have taken it apart and checked slider etc all seems ok , anyone got any suggestions for repair or solving the problem

thanks
Mike
 

·
Prof I T
Ting Tong
Joined
·
11,085 Posts
hi
with the thottle body split in half and using a cotton bud doused in inox preferably or wd40 wipe the slider and then dry it off.

If you are using pbpro or apb then re_calibrate the throttle.
 

·
Mike
Joined
·
629 Posts
Discussion Starter · #3 ·
Ta bigbird
I have done that , the throttle seems to go to 3/4 and is then full on , after 3/4 the cars slow down, forgot to mention that this is only with pbro throttle curve activated, it is okay without the throttle curve ie standard throttle on pbpro
 

·
Greg Gaub
Joined
·
14,645 Posts
By "throttle curve activated" do you mean within SSDC?
If so, note that SSDC with a C7030 base has no way to truly calibrate the throttles. For one as bad off as that one, it will be even worse.
Unfortunately, the solution is a new throttle, as any curve that you create to fix that one will make it into an on/off switch rather than a throttle, and require you to keep that controller identified so that you never use the curve on another controller, or a normal curve for that one.
There are some really bad SSD controllers out there, and it seems like you got one of them.
If you mean throttle curve with the base in standalone mode, no SSDC, well... don't use it. Just calibrate it and leave it. Use power levels if you need to make a car more manageable. Turning throttle curves on negates the calibration, as I understand it and how it seems to work on mine. It's one or the other, not both.
 
1 - 5 of 5 Posts
Top